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Product Overview

In this section...

“Ensures Software Reliability” on page 1-2
“Decreases Development Time” on page 1-2

“Improves the Development Process” on page 1-3

Ensures Software Reliability

You can ensure the reliability of your Ada applications by using PolySpace
verification software to prove code correctness and identify run-time errors.
Using advanced verification techniques, PolySpace software performs an
exhaustive verification of your source code.

®

Because PolySpace software verifies all possible executions of your code, it
can identify code that:

e Never has an error

® Always has an error

¢ Is unreachable

® Might have an error

With this information, you can be confident that you know how much of your

code 1s run-time error free, and you can improve the reliability of your code by
fixing the errors.

Decreases Development Time

Using PolySpace verification software reduces development time by
automating the verification process and helping you to efficiently review
verification results. You can use it at any point in the development process,
but using it during early coding phases allows you to find errors when it is
less costly to fix them.

You use PolySpace software to verify Ada source code prior to compilation.
To verify the source code, you set up verification parameters in a project, run
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the verification, and review the results. This process takes significantly less
time than using manual methods or using tools that require you to modify
code or run test cases.

A graphical user interface helps you to efficiently review verification results.
Results are color-coded:

® Green indicates code that never has an error.

® Red indicates code that always has an error.

® Gray indicates unreachable code (dead code).

® Orange indicates unproven code (code that might have an error).

This color-coding system helps you to identify errors quickly. You will spend

less time debugging because you can see the exact location of an error in the
source code. After you fix errors, you can easily run the verification again.

Using PolySpace verification software helps you to use your time effectively.
Because you know which parts of your code are error-free, you can focus on
the code that has definite errors or might have errors.

Reviewing the code that might have errors (orange code) can be
time-consuming, but PolySpace software helps you with the review process.
You can use filters to focus on certain types of errors or you can allow the
software to identify the code that you should review.

Improves the Development Process

PolySpace software makes it easy to share verification parameters and
results, allowing the development team to work together to improve product
reliability. Once verification parameters have been set up, developers can
reuse them for other packages in the same application.

PolySpace verification software supports code verification throughout the
development process:

¢ An individual developer can find and fix run-time errors during the initial
coding phase.

® Quality assurance can check overall reliability of an application.
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® Managers can monitor application reliability by generating reports from
the verification results.
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Product Components

The PolySpace products for verifying Ada code are:
PolySpace® Client™ for Ada
PolySpace® Server™ for Ada

The user interface includes:

® The Launcher for setting up verification parameters and starting
verifications.

® The Viewer for reviewing verification results.

® The Spooler for managing verifications that run on a server and
downloading results from a server to a client.
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Installing PolySpace Products

In this section...

“Finding the Installation Instructions” on page 1-6
“Obtaining Licenses for PolySpace® Client for Ada and PolySpace®
for Ada Products” on page 1-6

Server

Finding the Installation Instructions

The tutorials in this guide require both PolySpace Client for Ada and
PolySpace Server for Ada. Instructions for installing PolySpace products are
in the PolySpace Installation Guide. Before running PolySpace products, you
must also obtain and install the necessary licenses.

Obtaining Licenses for PolySpace Client for Ada and
PolySpace Server for Ada Products

See “PolySpace License Installation” in the PolySpace Installation Guide for
information about obtaining and installing licenses for PolySpace products.
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Working with PolySpace Software

In this section...

“Basic Workflow” on page 1-7

“The Workflow in This Guide” on page 1-8

Basic Workflow

The basic workflow for using PolySpace software to verify Ada source code is:

1
Setup project

Verify code

3
Review verification results

In this workflow, you:

1 Use the Launcher to set up a project file.
2 Verify code on a server or client.

You can use the Launcher to start the verification or you can select files
from a Microsoft® Windows® folder and send them to thePolySpace software
for verification. For verifications that run on a server, you can use the
Spooler to manage the verifications and download the results to a client.

3 Use the Viewer to review verification results.
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The Workflow in This Guide

The tutorials in this guide take you through the basic workflow, including the

different options for running verifications. The workflow that you will follow
in this guide is:

Create new project

Verify code

-

3
Review verification results

In this workflow, you will:

1 Create a new project that you can use for the other steps in the workflow.
This step is in the tutorial Chapter 2, “Setting Up a Project File”.

2 Verify a single package using demo Ada source code.
This step is in the tutorial Chapter 3, “Running a Verification”. In this

tutorial, you will verify the same package using three different methods
for running a verification. You will:

e Use the Launcher to start a verification that runs on a server.
e Use PolySpace In One Click to start a verification that runs on a server.

e Use the Launcher to start a verification that runs on a client.

3 Review the verification results.

This step is in the tutorial Chapter 4, “Reviewing Verification Results”.
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Learning More

In this section...

“Product Help” on page 1-9
“The MathWorks Online” on page 1-9

Product Help

To access the help that came with your installation, select Help > Help or
click the Help icon in the PolySpace window.

To access the online documentation for PolySpace products, go to:
/www.mathworks.com/access/helpdesk/help/toolbox/polyspace/polyspace.html
The MathWorks Online

For additional information and support, see:

www.mathworks.com/products/polyspace


http://www.mathworks.com/access/helpdesk/help/toolbox/polyspace/polyspace.html
http://www.mathworks.com/products/polyspace/index.html?s_cid=HP_FP_PS_PolySpace
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Related Products

In this section...

“PolySpace Products for Verifying C/C++ Code” on page 1-10

“PolySpace Products for Linking to Models” on page 1-10

PolySpace Products for Verifying C/C++ Code

For information about PolySpace products that verify C/C++ code, see the
following:

http://www.mathworks.com/products/polyspaceclientc/
http://www.mathworks.com/products/polyspaceserverc/

PolySpace Products for Linking to Models

For information about PolySpace products that link to models, see the
following:

http://www.mathworks.com/products/polyspacemodelsl/

http://www.mathworks.com/products/polyspaceumlrh/
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http://www.mathworks.com/products/polyspaceumlrh/
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About This Tutorial

In this section...

“Overview” on page 2-2

“Example Files” on page 2-2

Overview

You must have a project file before you can run a PolySpace verification of
your source code. In this tutorial, you will create a project that you can use to
run verifications in later tutorials.

Example Files

In this tutorial, you will verify the package example.adb that comes with the
PolySpace installation CD. You can learn more about the files and directories
required for this tutorial in “Preparing the Project Directories” on page 2-4.



Creating a New Project

Creating a New Project

In this section...

“What Is a Project?” on page 2-3

“Changing the Default Directory” on page 2-8

“Preparing the Project Directories” on page 2-4

“Opening the PolySpace Launcher” on page 2-5

“Creating a New Project to Verify an Ada Package” on page 2-10

What Is a Project?

In PolySpace, a project is a named set of parameters for a verification of your

software’s source files. A project includes:

e The location of source files and include directories

® The location of a directory for verification results

® Analysis options

You can create your own project or use an existing one. You can create and
modify a project using the Launcher graphical user interface.

A project file has one of the following file types:

Project Type File Extension

Description

Configuration cfg

Required for running a
verification. Does not
include generic target
processors.
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Project Type File Extension Description
PolySpace Project ppm Used to populate a
Model project with analysis

options, including
generic target
processors. Available
only in PolySpace
products for C/C++.

Desktop dsk Obsolete. Used in
earlier versions of
PolySpace software for
running a verification
on a client computer.

In this tutorial, you create a new project and save it as a configuration file
(.cfg).

Preparing the Project Directories

Before you start verifying Ada code with PolySpace software, you must know
the locations of the Ada source package and any other specifications upon
which it may depend either directly or indirectly. You must also know where
you want to store the verification results.

For each project, you decide where to store source files and results. For
example, you can create a project directory and then create separate
directories for the source files, include files, and results within the project
directory.

For this tutorial, prepare a project directory as follows:

1 Create a project directory named polyspace_project.

2 Open polyspace_project, and create the following directories:
® sources
® includes

® results



Creating a New Project

3 Copy the file example.adb from
Install directory\Examples\Demo_Ada_Single-File\sources
to
polyspace_project\sources
where Install directory is the installation directory.

4 Copy all files from
Install directory\Examples\Demo_Ada_Single-File\sources
to

polyspace_project\includes.

Opening the PolySpace Launcher

Use the PolySpace Launcher, a graphical user interface, to create a project
and start a verification.

To open the PolySpace Launcher:

® Double-click the PolySpace Launcher icon on your desktop.

e

PolySpace
Launcher

¢ If you have only PolySpace products for Ada installed on your computer,
skip this step. If you have both PolySpace products for Ada and C/C++ on
your system, the PolySpace Language Selection dialog box will appear.
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PolySspace Language Selection

Select a3 langusge

™ PolySpace for CIC++

¥ PolySpace for Ada

0K Cancel

Select PolySpace for Ada and click OK.

The PolySpace Launcher window opens.
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Specify Specify include

source files directories
1
T R
File Edit Tools Hel| 1
|Dom|alh X al# 8||» B *| @ ;
4 I
L ] - H |
- _l _l [y——
| Fiename | | Absolut| Path | I
Whalysis options !
1
—General | H
—TargetiCompilation ! S p ec |fY
—Compliance with standards: ana lySIS
—PalySpace inner settings ! options
—PrecizioniEcaling :
—Muttitasking !
1
1
1
1
1
1
1
1
Include directaries [-ada-inclufle-dir] :
1
1
1
1
1
Files extensions [—extensions—for—spec—files]I :
: ! Control
Results Directory [ -rezults-dir] | . .
I verification
5| '
- 1
1
Send to PolyEpace Server [= &Ex
= i
| Compile : 0% CDF& - 0% | Levell : 0% | Levelz - 0% Monitor
00:00:00 00:00:00 00:00:00 00:00:00 progress

1
|

1

1

' '
% Compile Log |
Stats :
1

Full Log |

View log

The Launcher window has three main sections.
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Use this For...
section...
Upper-left Specifying:

e Source files
® Include directories

¢ Results directory

Upper-right Specifying analysis options

Lower Controlling and monitoring a verification

You can resize or hide any of these sections. You learn more about the
Launcher window later in this tutorial.

Changing the Default Directory

PolySpace software allows you to specify the default directory that appears
in the directory browsers in dialog boxes. If you do not change the default
directory, the default directory is the installation directory. In this tutorial,
you change the default directory to the project directory that you created

in “Preparing the Project Directories” on page 2-4. Changing the default
directory to the project directory makes it easier for you to locate and specify
source files and include directories in dialog boxes.

To change the default directory to the project directory:

1 Select Edit > Preferences.

The Preferences dialog box appears.
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H Preferences

x|
: I Refnote Launcherl Miscellanenusl Fesult directory I Defautt direu:tu:ur':.fl
fenu title | Execution command |
-
Ok Ay Canicel

2 Select the Default directory tab.

3 Select Always use this specific folder if it is not already selected.

4 Enter or navigate to the project directory that you created earlier. In this
example, the project directory is C:\polyspace project.

The Preferences dialog box should now look like the following.
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x

Default falder for all brovwsers.

o Alvways use thiz specific folder |C:polyspace_project -, |

£~ lze the current path &= a default folder

Ok | Ay | Canicel |

5 Click OK to apply the changes and close the dialog box.

Creating a New Project to Verify an Ada Package

You must have a project, saved with file type .cfg, to run a verification. In
this part of the tutorial, you create a new project to verify example.adb.

You create a new project by:

® “Opening a New project” on page 2-11

® “Specifying the Source Files, Include Directories, and Results Directory”
on page 2-12

® “Specifying the Analysis Options” on page 2-15
e “Saving the Project” on page 2-16
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Opening a New project
To open a new project for verifying example.adb:

1 Select File > New Project.

The Choose the language dialog box appears:

x

| ik I Cancell

2 Select Ada95, then click OK.
The default project name, New_Project, appears in the title bar.

In the Analysis options section, the General options node expands with
default project identification information and options.
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File Edit Tools Help

PolySpace Launcher for Ada95 - New_Project - | Ellil

jDoW b & 0« B b @ @

Mewy Project

_I File Mame

Matne “alue

"'l - | :Search internal name fram the selected ling : ,@| I}:?

| Aksalute Path

Analysis options

I.J-]—General
—Session identifier Mes Project
—Date 2410772005
—Authar Imotahar
—FPraoject version 1.0

—Examine effects of scalar assignments

—Heep all intermediate files

—iCortinue even if red errars are detected

—Continue with the current configuration

| | o I

—Continue even on an uhsupported Linu: distributic

[+-TargetiCompilation

Include directoties [-ada-inciude-ir] I ampliance with standards

UIySpace inner setting=

Precision
urti‘tasking

Specifying the Source Files, Include Directories, and Results
Directory

To specify the source files, include directories, and results directory for the
verification of example.adb:

1 Click the green plus sign button in the upper right of the files section of
the Launcher window.

|

The Please select a file dialog box appears.
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Please select a file x|

Laak in: ﬂ ll El EI
[hincludes
[hresurts
BSDUI’CES
[ ) ¢* k) and (+ adls) files =]

™ Recurse subdirectories

—Source files [-sources] ~Directaries to include [-ada-include-dir]

[ [ B2

QK Cancel

2 The project directory polyspace_project should appear in the Look in
drop-down box. If it does not, navigate to that directory.

3 Select the directory includes and then click the green down arrow button
in the Directories to include section.

H

The path for the directory appears in the list of directories to include.

4 Double-click the directory sources.
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5 Select the file example.adb and then click the green down arrow button
in the Source files section.

F

The path for example.adb appears in the source files list.

Tip You can also drag directory and file names from an open directory
directly to the source files list or the directories to include list.

6 Click OK to apply the changes and close the dialog box.

7 In Files extensions, update the text in the box to: *.ad[sab]. This
indicates that specifications for the source code may be found in .ada,
.ads and .adb files. For example, you added the file util.adb to the
polyspace_project\includes directory in the tutorial “Preparing the
Project Directories” on page 2-4. If you do not update Files extensions
to include .adb files, PolySpace will not recognize util.adb as a valid
specification path. This will cause the verification process to fail.

8 In Results Directory, specify the directory for the verification results.
Enter the path for the results directory that you created earlier. In this
example, the results directory is C: \polyspace_project\results.

The files section in the upper left of the Launcher window now looks like this.



Creating a New Project

ey Project rl - |

File Matme Absolute Path

example adb Clpolyspace_projectizources

| Ihclude directories [-ada-include-dir]

- |C:'I.pl:nlyspace;uruject'l.includes

Files extensions [ -extensions-for-spec-files]|*.ad[zak]

Results Directory [-results-dir]

IC:W.pnlyspace;umjecﬂresurtsl -~ |

Specifying the Analysis Options

The analysis options in the upper-right section of the Launcher window
include identification information and parameters that PolySpace software
uses during the verification process. For more information about analysis
options, see “Options Description” in the PolySpace Products for Ada
Reference.

To specify the analysis options for this tutorial:
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1 In the General section, change the Session identifier to
Example_Project.

Note The session identifier cannot contain spaces.

2 In the General section, select the Continue even if red errors are detected
check box.

You learn about red errors in Chapter 4, “Reviewing Verification Results”.
3 Keep the default values for all other options.
Saving the Project
To save the project:

1 Select File > Save project. The Save the project as dialog box appears.
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Look it: IE,'] polyspace_project LI _ﬁ ,.5'

x|

E Ia includes
it 1L resuts

hily Recent O I R e

My Metwork ..

Session identifier ||

Files of type: I*_.:fg ll

ik

Cancel

2 In Look in, leave the default directory, polyspace_project.

3 In Session identifier, enter example.

4 In Files of type, leave the default *.cfg. You must have a project file

with type cfg to run a verification.

Note You can also run a verification with a project file of type dsk. Older
versions of PolySpace software created files with type dsk for use with
verifications running on a desktop PC. For more information about the dsk

file type, see “What Is a Project?” on page 2-3.

5 Click OK to save the project and close the dialog box.
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Running a Verification

e “About This Tutorial” on page 3-2
® “Opening the Project” on page 3-4

e “Using the Launcher to Start a Verification That Runs on a Server” on
page 3-5

¢ “Using PolySpace In One Click to Start a Verification That Runs on a
Server” on page 3-15

e “Using the Launcher to Start a Verification That Runs on a Client” on
page 3-22
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About This Tutorial

In this section...

“Overview” on page 3-2

“Before You Start” on page 3-3

Overview

Once you have created the project example.cfg as described in “Creating a
New Project” on page 2-3, you can run the verification.

You can run a verification on a server or a client.

Use...

For...

Server

® Best performance

Large files (more than 800 lines of code including comments)

Multitasking

Client

® An alternative to the server when the server is busy

Small files with no multitasking

Note Verification on a client takes more time. You might
not be able to use your client computer when a verification is
running on it.

You can start a verification using the Launcher or using PolySpace In One
Click. With either method, the verification can run on a server or a client.
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Use... For...

Launcher A basic way to start a verification.

You specify the source files in the project file.
With the project file open, you click a button to
start the verification.

PolySpace In One Click | A convenient way to start the verification of
several files which use the same verification
options.

Once you specify the project file containing the
verification options, you specify the source files
by selecting them from a Microsoft Windows
folder. You start the verification by sending the
selected files to PolySpace software.

In this tutorial, you learn how to run a verification on a server and on a
client, and you learn how to start a verification using the Launcher and using
PolySpace In One Click. You verify the package example.adb three times
using a different method each time. You use:

1 The Launcher to start a verification that runs on a server.
2 PolySpace In One Click to start a verification that runs on a server.

3 The Launcher to start a verification that runs on a client.

Each verification stores the same results in polyspace_project\results.
You review these results in the tutorial Chapter 4, “Reviewing Verification
Results”.

Before You Start

Before you start this tutorial, you must complete Chapter 2, “Setting Up a
Project File”. You use the directories and project file, example.cfg, from
that tutorial to run the verifications.

3-3



3 Running a Verification

Opening the Project

To run a verification, you must have an open project file. For this tutorial, you
use the project file example.cfg that you created in Chapter 2, “Setting Up a
Project File”. Open example.cfg if it is not already open.

To open example.cfg:

1 If the PolySpace Launcher is not already open, open it by double-clicking
the PolySpace Launcher icon.

2 Select File > Open project.

The Please select a file dialog box opens.
3 In Look in, navigate to polyspace_project.
4 Select example.cfg.

5 Click Open to open the file and close the dialog box.



Using the Launcher to Start a Verification That Runs on a Server

Using the Launcher to Start a Verification That Runs on
a Server

In this section...

“Starting the Verification” on page 3-5
“Monitoring the Progress of the Verification” on page 3-6
“Downloading Results from the Server to the Client” on page 3-10

“Troubleshooting a Failed Verification” on page 3-12

Starting the Verification
In this part of the tutorial, you run the verification on a server.

To start a verification that runs on a server:

1 Select the Send to PolySpace Server check box next to the Execute
button in the middle of the Launcher window.

Send to Paly=pace Server v i’ Execute |

Note If you select Set this option to use the server mode by default
in every new project in the Remote Launcher pane of the preferences,
the Send to PolySpace Server check box is selected by default when you
create a new project.

2 Click Execute.

Note If you see the message Verification process failed, click OK
and go to “Troubleshooting a Failed Verification” on page 3-12.

The verification has three main phases:
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a Checking syntax and semantics (the compile phase). Because PolySpace
software 1s independent of any particular Ada compiler, it ensures that
your code is portable, maintainable, and complies with ANSI® standards.

b Generating a main if it does not find a main and the Generate a Main
option is selected. For more information about generating a main, see
the section “-main-generator” in the “Options Description” chapter of the
PolySpace Client/Server for Ada User’s Guide.

¢ Analyzing the code for run-time errors and generating color-coded
diagnostics.

The compile phase of the verification runs on the client. When the compile
phase finishes:
* A message dialog box tells you that the verification is completed. This

message means that the part of the verification that takes place on the
client is complete. The rest of the verification runs on the server.

® A message in the log area tells you that the verification was transferred
to the server and gives you the identification number (Analysis ID) for
the verification. For this verification, the identification number is 2.

Cumpile Search 44 | (1

| M) stets | stotus | Description | Fie |Line| ca
@ Full Log [ PaolySpace Launcher for Ada95 verification start at Jan 15, 2009,
I. The analysiz has been gueued with ID=2

3 When you see the message Verification process completed, click OK
to close the message dialog box.

4 Stop the Launcher by clicking File > Quit.

Monitoring the Progress of the Verification

You monitor the progress of the verification using the PolySpace Queue
Manager (also called the Spooler).

To monitor the verification of Example Project:
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1 Double-click the PolySpace Spooler icon:

The PolySpace Queue Manager Interface opens.

i PolySpace Queue Manager Interface

Operations  Help

D | Author Application Fesulks directony CPU| Statuz  |Date |L
vour_name  Example_Project C:hpolyspace projectiresults anse running 008,

Tip You can also open the Polyspace Queue Manager Interface by clicking

the PolySpace Queue Manager icon E in the PolySpace Launcher toolbar.

2 Point anywhere in the row for ID 1.
3 Right-click to open the context menu for this verification.

Follows Progress, .,

Wiew Log File, .,

Download Results., ..

Cownload Resulks And Remove From Queue. ..

Mawve Down In Queues

Stop And Download Resulks, .,
Stop And Remove From Queue. ..

Rermove From Queue, ..
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4 Select View log file.
A window opens displaying the last one-hundred lines of the verification.

JPolyspace’,PolySpace_Common',Remotel auncher', whin',ps

GUI files generation complete.

Generating remote file
Done

Certain (red? errors have been detected in the analysed code duy
SE .

Analysis continuwing because the option —continue—with-red-error

SoE-E oo —aE o -Jef -eF - Jof e —aE-Jof-Jef—eF-JuF-Jof e -3aF-Jof-3uf—ef-JuE-Juf e -3af-Juf-Juf e -eF-Juf-Jefef-of-Jef e —eFaf—Jef e -eFJf-Jef e -SaE-Tof-Je e -Juf-Jof e Sef-Juf-Juf-Sef-JeE-Juf-ef-
CaTakal

#3#% Level 4 Software Safety Analysis done

CaTalad

3oE-30E 30 ~JuE—Jf—JaE—JaE—eE e 3o 3o -JaF-JE-JaE-JaE e e eE 3o -Jef-JnE-JuE-Juf-Jef—Jef-ef—uf—Juf-Jaf-JeE-JeE-Jef-ef—Jef—Juf—Juf-Jaf—JaE e e oo -Jef-JE-JaE-JaE-JeE e -JeE—ef-Jef-Jf-Jnf-Jnf-Jef-Jef-ef-ef-
Ending at: Apr 11, 26088 12:29:8

Uzer time for pass4d: 35.8real. 35.8u + Bs

Uzer time for polyspace—c: 176.5real. 176.5u + A=

EaXaxad

#*x% End of PolySpace Uerifier analysis
CaTakal

Presz enter to close the window ...

5 Press Enter to close the window.
6 Select Follow Progress from the context menu.

A Launcher window labeled PolySpace follow remote analysis
progress for Ada appears.
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PolySpace follow remote code verification progress - | Ellil

File Edit Help

Sendto PolySpace Server v B Execute | a Stop Execution |

Cormpile : 100% 2 ;4 00%: 5 100% Leweld : 100% Total
00:00; 04 00:00:27 00:00:15 00:00:41 00;00;22 00:00:18 000211
% Compile Search: 44 I 42
B siais N

Generating results in a spreadsheet format in C:hZPolyipace)\Poly3pace RLDatashan

Generation complete

Generating remote £ile

Dote

Ea e e e i i e i i i i e e i i e e e i e e i e e i e i e e i i e i i e
FEE

F+*% Lewel 4 Software Safety Analysis done
kg

=

ok e i o o e o e ol e e o o i o o o ol e e e e e o o o o ok o o o
=
L|_I

Kl |

irification completed

You can monitor the progress of the verification by watching the progress
bar and viewing the logs at the bottom of the window. The word
processing appears under the current phase. The progress bar highlights
each completed phase and displays the amount of time for that phase.

The logs report additional information about the progress of the verification.
The information appears in the log display area at the bottom of the
window. The full log displays by default. It display messages, errors, and
statistics for all phases of the verification. You can search the full log by
entering a search term in the Search in the log box and clicking the left
arrows to search backward or the right arrows to search forward.

7 Click the Compile Log button to display compile phase messages and
errors. You can search the log by entering search terms in the Search in
the log box and clicking the left arrows to search backward or the right
arrows to search forward.

8 Click the Stats button to display statistics, such as analysis options,
stubbed functions, and the verification checks performed.
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9 Click the refresh button
G5 |
to update the stats log display as the verification progresses.
10 Select File > Quit to close the progress window.
11 Wait for the verification to finish.

When the verification is complete, the status in the PolySpace Queue
Manager Interface changes from running to completed.

i PolySpace Queue Manager Interface
Operations  Help

D | Author Application Rezultz directom CPU| Statuz | Date

wour_name  Example_Project C:hpolyzpace_projecthresults anse zompletec 008,

Downloading Results from the Server to the Client

At the end of the verification, the results are on the server. To download the
results to your client:

1 In the PolySpace Queue Manager Interface, select Download Results
from the context menu for the verification.

The Browse For Folder dialog box appears with the
polyspace_project\results folder selected.
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Directory where ko store the results

) Perl -
=) PalySpace
=l 15 polyspace_project

I includes J

I3 resulks
I sources

I3 PalvSpace_Results -
= I _*|_I

Folder: I results

Make Mew Falder | (0] 4 I Cancel |

2 Click OK to close the dialog box.

A dialog box appears telling you that the download is complete and asking
if you want to open the PolySpace Viewer.

Queston =

Downlaad completed, Da you wank ko open PalvSpace Yiewer 7

Yes Mo |

3 Click No.

4 Select Remove From Queue from the context menu.

A dialog box appears asking you to confirm that you want to remove the
verification from the queue.
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Question =

Do wou really want to removwe the analvsis 1 From the queue ?

Yes Mo |

5 Click Yes.

Note

¢ To download the results and remove the verification from the queue,
select Download Results And Remove From Queue from the context
menu.

¢ [f you download results before the verification completes, you get partial
results and the verification continues.

6 Select Operations > Exit to close the PolySpace Queue Manager
Interface.

Once the results are on your client, you can review them using the PolySpace
Viewer. You review the results from the verification in Chapter 4, “Reviewing
Verification Results”.

Troubleshooting a Failed Verification

When you see a message that the verification failed, it indicates that
PolySpace software could not perform the verification. The following sections
present some possible reasons for a failed verification.

Hardware Does Not Meet Requirements

The verification fails if your computer does not have the minimal hardware
requirements. For information about the hardware requirements, see

www.mathworks.com/products/polyspaceclientada/requirements.html.


http://www.mathworks.com/products/polyspaceclientc/requirements.html
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To determine if this is the cause of the failed verification, search the log for
the message:

Errors found when verifying host configuration
You can:

e Upgrade your computer to meet the minimal requirements.

® Select the Continue with current configuration option in the General
section of the Analysis options and run the verification again.

You Did Not Specify the Location of Included Files

If you see a message in the log, such as the following, either the files are
missing or you did not specify the location of included files.

Verifier found an error in example.adb:23:14: “runtime_error
(spec)" depends on "types (spec)"

For information on how to specify the location of include files, see “Creating a
New Project to Verify an Ada Package” on page 2-10.

PolySpace Software Cannot Find the Server

If you see the following message in the log, PolySpace software cannot find
the server.

Error: Unknown host

PolySpace software uses information in the preferences to locate the server.
To find the server information in the preferences:

1 Select Edit > Preferences.

2 Select the Remote Launcher tab.
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Tools heny  Remote Launcher I Miscellaneuusl Feszult directory I Default direu:tu:ur':.fl

X

~Retmote configuration

¥ =et this option to use the zerver mode by default in every newe project

Mate: this option iz mandatory when the project contains multitasking options.

The multitazking options will ke ignored athervwise,

) Automatically detect the remate zerver

i Use the followving server and port

The =erver natme "localhost" can be uzed if the server iz the local machine.

Ay Canicel

By default, PolySpace software automatically finds the server. You can
specify the server by selecting Use the following server and port and
providing the server name and port. For information about setting up a
server, see the PolySpace Installation Guide.
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Using PolySpace In One Click to Start a Verification That
Runs on a Server

In this section...

“Overview of PolySpace In One Click” on page 3-15
“Setting the Active Project” on page 3-15

“Sending the Files to PolySpace Software” on page 3-17

Overview of PolySpace In One Click

In a Microsoft Windows environment, PolySpace software provides a
convenient way to streamline your work when you want to verify several
packages using the same set of options. Once you have set up a project file
that has the options you want, you designate that project as the active project,
and then send the source files to PolySpace software for verification. You do
not have to update the project with source file information. This process is
called PolySpace In One Click.

In this part of the tutorial, using PolySpace In One Click, you learn how to:

1 Set the active project.

2 Send source files to PolySpace software for verification.

Setting the Active Project

The active project is the project that PolySpace In One Click uses to verify
the packages that you select. Once you have set an active project, it remains
active until you change the active project. PolySpace software uses the
analysis options from the project; it does not use the source files or results
directory from the project.

To set the active project:

1 Right-click the PolySpace In One Click icon in the taskbar area of your
Windows desktop:
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The context menu appears.

Set active project k

Open ackive project - Training_Project

Viewer

Launcher

1 &1

Spoaler

Help »

Exit

2 Select Set active project > Browse from the menu.

The Please set an active project dialog box appears:

Please set an active project.

Look in: IE} polyspace_project

xl = & Er

el )

|E. ILS)includes
I results
IC5) sources
example.cfg
My Documents
mathworlcs
i
=
File name: || ﬂ
Flaces
Files of type: I PalySpace configuration files j

pen

Cancel

I
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3 In Look in, navigate to polyspace _project.

4 Select example.cfg.

5 Click Open to apply the changes and close the dialog box.

Sending the Files to PolySpace Software

You can send several packages to PolySpace software for verification. For this
tutorial, you send one package, example.adb.

To send example.adb to PolySpace software for verification:
1 Navigate to the directory polyspace_project\sources.
2 Right-click the file example.adb.

The context menu appears.

Mame = I

Open
Qpen with WordPad
ca Scan for viruses..,

& 17Arc 3
&3 WinZip 3

Send To »

Cut
Copy

Create Shortcut
Delete
Renarme

Properties

3 Select Send To > PolySpace.
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Mame = | Size | Type
7KB ADB File

Open
Cpen with WordPad
ca Scan for viruses..,

& IZArc 3

5 WinZip 3

({7 Compressed (zipped) Folder
Cut @ Desktop {create shortout)
Copy (# Macromedia FreeHand MY
Create Shartcut _J Mail Recipient
Delete [} My Documents
Rename

PolySpace

Properties

The PolySpace basic settings dialog box appears.
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E PolySpace basic settings [ ADA 95 ] - |I:I|5|

Settings

Precision IOQ j

Passes IPassZ (Software Safety Analysis level 2) j

Parameters

Results directory |C:‘-,pnI'_.fspau:e_pru:nject‘-,results | [E

Main | |

Scope

C:polyspace_project’sournces example adb

[+

[¢] Send to PolySpace Server (¥ Execute | @ Cancel |

4 Make sure that Results directory is polyspace project\results.
5 Select the Send to PolySpace Server option if it is not already selected.

6 Leave the default values for the other parameters.
Click Execute.

The verification log appears.
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E C:\polyspace_project\results =10l x|
E= & e -

-= Yerifier found a warning in example.adb:199:07: ™" iz never azzigned a value:l
Stubking unknawen funclions and procedures ...
... Stubbing subprogram body runtime_error.procedure_stub

ffffffffffffffffffffffffffffffffffffffffffffffffffffffffff

ffffffffffffffffffffffffffffffffffffffffffffffffffffffffff

Ending at: Jul 22, 2008 14:6:17

Uzer time for compile: 1.2real, 1.2u + 0z
Generating remote file

Dane

Uzer time for polyzpace-adals: 2.8real, 2.8u + 03

b33

#2End of PolySpace erifier analysiz

333

Adding the analysis to the queue ..

Transfering the archive to the server ..

Transfer completed.

Analysiz 0o

The analysiz has been gueusd. “ou may followe itz progress using the SF":":”EV-_ILI
4| b

|The analyziz haz been succeszfully done

The compile phase of the verification runs on the client. When the compile

phase completes:

® You see the message:

End of PolySpace Verifier analysis

* A message in the log area tells you that the verification was transferred
to the server and gives you the identification number (Analysis ID) for the

verification. For this verification, the identification number is 1.

e Monitor the verification using the Spooler. For information on using the
Spooler to monitor a verification on a server, see “Monitoring the Progress

of the Verification” on page 3-6.
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® When the verification completes, download the results to
polyspace _project\results. For information on downloading results

from a server to a client, see “Downloading Results from the Server to the
Client” on page 3-10

You review the results in Chapter 4, “Reviewing Verification Results”.
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Using the Launcher to Start a Verification That Runs on a

In this section...

“Starting the Verification” on page 3-22
“Monitoring the Progress of the Verification” on page 3-23
“Completing the Verification and Stopping the Launcher” on page 3-24

“Stopping the Verification Before It Completes” on page 3-25

Starting the Verification

For the best performance, run verifications on a server. If the server is busy
or you want to verify a small package, you can run a verification on a client.

Note Because a verification on a client can process only a limited number
of variable assignments and function calls, the source code should have no
more than 800 lines of code.

To start a verification that runs on a client:

1 Open the Launcher if it is not already open.
2 Open the project file example.cfg if it is not already open.

For information about opening a project file, see “Opening the Project”
on page 3-4.

3 Make sure that the Send to PolySpace Server check box is clear.

4 If you see a warning that multitasking is not available when you run
a verification on the client, click OK to continue and close the message

box. This warning only appears when you clear the Send to PolySpace
Server check box.

5 Click the Execute button.
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},‘f Execute |

6 If you see a caution that PolySpace software will remove existing results
from the results directory, click Yes to continue and close the message
dialog box.

The progress bar and logs area of the Launcher window become active.

Note If you see the message Verification process failed, click OK
and go to “Troubleshooting a Failed Verification” on page 3-12.

Monitoring the Progress of the Verification

You can monitor the progress of the verification by watching the progress bar
and viewing the logs at the bottom of the Launcher window.

Send to PolySpace Server r B Execute | @
Cornpile : 100% LU= | Lewvell : 0% | Lewel2 : 0% | Lenwe
00:00: 04 00:00:1 2 00:00: 00 00:00: 00 0o:
Campile Search; 44 I (13
Stats | Status | Description | File: | Line | col

@ Full Log 1 |F‘|:|IySpa|:e Launcher for Ada23 .. | | |

The progress bar highlights the current phase in blue and displays the
amount of time and completion percentage for that phase.

The logs report additional information about the progress of the verification.
To view a log, click the button for that log. The information appears in the
log display area at the bottom of the Launcher window. Follow the next steps

to view the logs:

1 The compile log displays by default.
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This log displays compile phase messages and errors. You can search the
log by entering search terms in the Search in the log box and clicking the
left arrows to search backward or the right arrows to search forward.

2 Click the Stats button to display statistics, such as analysis options,
stubbed functions, and the verification checks performed.

3 Click the refresh button

_@ |

to update the display as the verification progresses.

4 Click the Full Log button to display messages, errors, and statistics for all
phases of the verification.

You can search the full log by entering a search term in the Search in
the log box and clicking the left arrows to search backward or the right
arrows to search forward.

Completing the Verification and Stopping the
Launcher

When the verification completes, a message dialog box appears telling you
that the verification is complete and asking if you want to open the Viewer.
For this tutorial, do not open the Viewer at this point.

E x|

@ Werification process completed,
Do you wank ko launch PolySpace Viewer #

To indicate that you do not want to open the Viewer:
¢ (Click Cancel.

You can also open the Viewer from the Launcher toolbar, but for this tutorial,
you do not do this. For this tutorial, close the Launcher.
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To close the Launcher:
® Select File > Quit.

In the tutorial Chapter 4, “Reviewing Verification Results”, you open the
Viewer and review the verification results.

Stopping the Verification Before It Completes

You can stop the verification before it completes. If you stop the verification,
results will be incomplete, and if you start another verification, the verification
starts over from the beginning.

To stop a verification:

1 Click the Stop Execution button.

@ Stop Execution |

A warning dialog box appears.

waming x|

@ Do wou really want to stop the current execution ?

o |

2 Click Yes.

The verification stops and the message Verification process stopped
appears.

3 Click OK to close the Message dialog box.
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Note Closing the Launcher window does not stop the verification. To resume
display of the verification progress, open the Launcher window and open the
project that you were verifying when you closed the Launcher window.
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Reviewing Verification
Results

e “About This Tutorial” on page 4-2

® “Opening the Viewer and the Verification Results” on page 4-3
¢ “Exploring the Viewer Window” on page 4-5

* “Reviewing Results in Expert Mode” on page 4-9

® “Reviewing Results in Assistant Mode” on page 4-25

® “Generating Reports of Verification Results” on page 4-32
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About This Tutorial

In this section...

“Overview” on page 4-2

“Before You Start” on page 4-2

Overview

In the previous tutorial, Chapter 3, “Running a Verification”, you completed
a verification of the package example.adb. In this tutorial, you explore the
verification results.

PolySpace software provides a graphical user interface, called the Viewer,
that you use to review results. In this tutorial, you learn:

1 How to use the Viewer, including how to:

® Open the Viewer and open verification results.

Select the Viewer mode.

Explore results in expert mode.

Explore results in assistant mode.

® Generate reports.

2 How to interpret the color-coding that PolySpace software uses to identify
the severity of an error.

3 How to find the location of an error in the source code.

Before You Start

Before starting this tutorial, complete the tutorial Chapter 3, “Running a
Verification”. In this tutorial, you use the verification results stored in this file:

polyspace_project\results\RTE_px_02_Example_Project_ LAST_RESULTS.rte.
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Opening the Viewer and the Verification Results

In this section...

“Opening the Viewer” on page 4-3
“Selecting the Viewer Mode” on page 4-3

“Opening the Results” on page 4-4

Opening the Viewer

You use the Viewer to review verification results. Open the Viewer if it is
not already open.

To open the Viewer:

® Double-click the PolySpace Viewer icon:

Note You can also open the Viewer from the Launcher by clicking the Viewer
icon in the Launcher toolbar with or without an open project.

Selecting the Viewer Mode

You can review verification results in expert mode or assistant mode:

® In expert mode, you decide how you review the results.

¢ In assistant mode, PolySpace software guides you through the results.

You switch from one mode to the other by clicking a button in the Viewer
toolbar. For this part of the tutorial, the Viewer should be in expert mode. If
the Viewer is in expert mode, the switch mode button in the toolbar displays
Assistant.
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G Assistant

If the Viewer is not in expert mode, click the mode button to switch to expert
mode.

{J§_'.‘ Expert |

You learn more about expert and assistant modes later in this tutorial.

Opening the Results

To open the verification results:

1 Select File > Open.

2 In the Please select a file dialog box, navigate
to polyspace _project\results and select the file
RTE_px_02_Example_Project_LAST_RESULTS.rte.

3 Click the Open button.

The results appear in the Viewer window.

Note The file RTE_px_02_Example Project LAST_RESULTS.rte represents
the verification with the highest level of precision. The lower level results files
that you see in the polyspace_project\results directory represent lower
precision verifications.
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Exploring the Viewer Window

In this section...

“Overview” on page 4-5

“Reviewing the Procedural Entities View” on page 4-7

Overview
The PolySpace Viewer window looks like this.

Coding review progress view Selected check view
nPuhSpace\ﬁewer-C:\pulvspaceiject\rﬁuIts\RTEfoOZﬁExamﬂeﬁijmJASILII'S.I_T‘SJIE - Ellll
File EHt Windows Help
£

J S| B = o= | i B O e 1 J nest J o i J Userdet = G§,As:sistant|
J Revidued filter off 'I‘ X 3 F;gt Sy oz e SR | con feow | MY mser TROAT wre ke I WL UNR DR

Coding reviews progress Count | Pr. I: Ma check currently selected
Mo check selected n'a nia
i reviewved § nb to reviewr (nfa) nia iz
Software reliabilty indicstor nia hiz O @I

e FIF I I K [E v v o o
= e S
[B-ADA 1 |25 Example_Project
f,EH’KDATA 1 &RuNTlME_ERRDR BE
EE—RANDUM 1 [E-RUNTIME_ERROR BI
&—RUNTIME_ERRUR 6| 4 20 3
}—RLWTIME_ERRDR$SPEC 12
- SENSITITY 1

F ST
<| | 0|

Exarple_Project Source file: example.adb RUNTIME_E+OR Line: 23 Cofurmn: unknowr
Procedural Variables Source code Call tree
entities view view view view
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The appearance of the Viewer toolbar depends on the Viewer mode. Because
the Viewer is in expert mode, the expert mode toolbar is displayed.

,ﬁ E E Q) i J N-3HR %VJ '.%E i Jlm ._§'* Assistant

FROC
v »

I NI SCAL I I NIU FLOAT I
‘ logal <0 ERCP gopp | COR FOW ) othar A=ERT  “qupL MWTC  K-NTC | NTL UNR VoA

In both expert mode and assistant mode, the Viewer window has six sections
below the toolbar. Each section provides a different view of the results. The
following table describes these views.

This view...

Displays...

Procedural entities view (lower left)

List of the diagnostics (checks) for
each file and function in the project

Source code view (lower right)

Source code for a selected check in
the procedural entities view

Coding review progress view (upper
left)

Statistics about the review progress
for checks with the same type and
category as the selected check

Selected check view (upper right)

Details about the selected check

Variables view

Information about the global
variables declared in the source code

Note The file that you use in
this tutorial does not have global
variables.

Call tree view

Tree structure of function calls

You can resize or hide any of these sections. You learn more about the Viewer

window later in this tutorial.
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Reviewing the Procedural Entities View

The procedural entities view, in the lower-left part of the Viewer window,
displays a table with information about the diagnostics for each file in the
project. The procedural entities view is also called the RTE (Run-Time
Error) view. When you first open the results file from the verification of
example.adb, the procedural entities view looks like this.

Procedural entities iX | Line | .| % | Deta
B rce OOENEC
T 1 0
- PKDATA 1 0
H-RANDOM 1 0
H-RUNTIME_ERROR 6| 4 | 23 83 lewamg
| —RUNTIME_ERROR$SPEC 12 0 exam
FSENSITRATY 1 o

The package RUNTIME_ERROR is red because its contains at least one definite
run-time error. PolySpace software assigns each package the color of the
most severe error found in that package. Note that the other entities
displayed for the example project are simply black. This indicates that they
contain specifications that were used for the analysis. The first column of
the Procedural entities view names the procedural entity (the package or
function). The following table describes some of the other columns in the
procedural entities view.

Column Indicates

Heading

| 7 I Number of red checks (for operations where an error always
d occurs)

J Number of gray checks (for unreachable code)
x
J Number of orange checks (warnings for operations where
an error might occur)
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Column Indicates
Heading
ﬂ Number of green checks (for operations where an error

never occurs)

ﬁ Total number of red, green, and gray checks (an indication
of the level of proof)

Tip If you see three dots in place of a heading, J, resize the column until you
see the heading. Resize the procedural entities view to see additional columns.

Note You can select which columns appear in the procedural entities view
by editing the preferences. To learn how to add a Reviewed column, see
“Making the Reviewed Column Visible” on page 4-13.

What you select in the procedural entities view determines what is displayed
in the other views. In the following examples, you learn how to use the views
and how they interact.
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Reviewing Results in Expert Mode

In this section...
“What Is Expert Mode?” on page 4-9

“Switching to Expert Mode” on page 4-9

“Reviewing Checks in Expert Mode” on page 4-9
“Reviewing Additional Examples of Checks” on page 4-16
“Filtering the Types of Checks That You See” on page 4-19

What Is Expert Mode?

In expert mode, you can see all checks from the verification in the PolySpace
Viewer. You decide which checks to review and in what order to review them.

Switching to Expert Mode

If the Viewer is in expert mode, the switch mode button displays Assistant.
If the Viewer is in assistant mode, the switch mode button displays Expert.
To switch from assistant to expert mode:

e (Click the Viewer mode button:
~'§.'.‘ Expert

The Viewer window toolbar displays buttons and menus specific to expert
mode.

Reviewing Checks in Expert Mode
In this part of the tutorial, you learn how to use the Viewer window views to

examine checks from a verification. This part of the tutorial covers:
e “Selecting a Check to Review” on page 4-10
¢ “Displaying the Calling Sequence” on page 4-11

e “Tracking Review Progress” on page 4-12
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* “Making the Reviewed Column Visible” on page 4-13

Selecting a Check to Review

In the procedural entities view, RUNTIME_ERROR is red, indicating that this
package has at least one red check. To review a red check in RUNTIME_ERROR:

1 In the procedural entities section of the window, expand RUNTIME_ERROR.
2 Expand the red function SQUARE_ROOT.

A color-coded list of the checks performed on SQUARE_ROOT appears:

| v vosn
| | voaz
| I—v" OF L4
| L% ecrs

Each item in the list of checks has an acronym that identifies the type of
check and a number. For example, in EXCP.5, EXCP stands for Arithmetic
Exception. For more information about different types of checks, see
“Check Descriptions” in the PolySpace Client/Server for Ada User’s Guide.

3 Click on the red EXCP.5.

The source code view displays the section of source code where this error
occurs.
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159
1a0
18l
laz
la3
led
165
1a6
1a7
1ad
1a9
170
171
172
173
174
175
176

]

—iDix

-

-- Here we demonstrate PolySpace Verifier's ability to trace numeric J
-- constraints across many different arithmetic operations.
-— The table provided below the example shows the domain of
-- walues for the expressions in the exanple.
procedure 3gquare Foot _conv (alpha : in float; ¥ @ out long float) is
begin

¥ i= (1.5 + cos (long floatialphaj))s5.0;
end Fgquare FRoot_conwv:

Beta : Long_Float;
procedure 3cuare Root is
Alpha @ Float := Random.random;

=
ramma : long float:
begin
dquare_Foot_conv (Alpha, Eetaj:
Beta := Beta - 0.75;
Gawma := zgrtiEeta); -- always sgrt(negative number)
end Square Root; ﬂ
3

4 At line 175 of the code, click on the red code.

An error message box appears indicating that when the local float variable
Gamma is computed at line 175, the operation will cause a run-time error
because the parameter passed to sqrt is always negative.

Displaying the Calling Sequence
You can display the calling sequence that leads to the code associated with a
check. To see the calling sequence for the red EXCP.5 check in SQUARE_ROOT:

1 Expand SQUARE_ROOT.
2 Click on the red EXCP.5.

%

3 Click the call graph button in the toolbar.
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A window displays the call graph.

Bl Error call graph for RUNTIME_ERROR.SQUARE_ROOT.EXCP.S -

RINTIME EEREROE FIINTIME _EREOE

MATNETE FQUARE _ROOT

=10l x|

FEUNTIME ERROE

ExXCP. 5

The code associated with EXCP.5 is in SQUARE_ROOT. The function MAINRTE

calls SQUARE_ROOT.

Tracking Review Progress

You can keep track of the checks that you have reviewed by marking them. To
mark that you have reviewed the red EXCP.5 check in SQUARE_ROOT:

1 Expand SQUARE_ROOT.

2 Click the red EXCP.5.

A table with statistics about the review progress for that category and
severity of error appear in the upper-left part of the window.

Coding reviewy progress

Count | Progress |

[[nky EXCP reviesaed §nb EXCP to resview (Red) 071 ]
[l revieweed i ta review [Fed) oy ]
Softweare reliability indicator 37155 E7

The Count column displays a ratio and the Progress column displays the
equivalent percentage. The first row displays the ratio of reviewed checks
to the total number of checks that have the same color and category as the
current check. In this example, it displays the ratio of reviewed red EXCP
checks to total red EXCP errors in the project.
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The second row displays the ratio of reviewed checks to total checks that
have the same color as the current check. In this example, this is the ratio
of red errors reviewed to total red errors in the project. The third row
displays the ratio of the number of green checks to the total number of
checks, providing an indicator of the reliability of the software.

Information about the current check (the red EXCP.5) appears in the

upper-right part of the Viewer window.

example adb F SQUARE_ROOT fline 175 § column 15

Fanma

1= ggrt(Beta); -- always sqrtinegative humber)

r &

certain f£loat certain £loat failure of correctness condition [argument of 30RT must be

bositive]

3 Select the check box to indicate that you have reviewed this check. You can

enter a comment in the comment box.

The Coding review progress part of the window updates the ratios of

errors reviewed to total errors.

Coding review progress Count | Progress |
[Nk EXCP reviesaved § nb EXCP to resview (Red) 11 100
b reviewed i rib to review [Red) 107 14
Softweare reliakility indicator 37155 B7

Making the Reviewed Column Visible

You can change the PolySpace Viewer preferences so that the procedural

entities part of the window displays a Reviewed column.

1 Select Edit > Preferences.

2 Select the Table options tab.

4-13



4 Reviewing Verification Results

3 Under Display columns in RTE view, select the Reviewed check box.

Now the Table options tab looks like this.

HPreferences PolySpace Yiewer

Tools Menu  Table options | Taclkars l:nptil:nnsl Mizcelaneous

~Dizplay columns in RTE wigw ~Dizsplay columns Yariable
¥ Gray ¥ i read
v Cirange [V B werite
¥ Green v Wiriting Tasks
V¥ Line v Reading Tasks
¥ Column [ Protection
¥ Tatal Selectivity | Usage
¥ Detsils I+ Line
¥ Reviewsd ¥ Colurn
[ comnents [V File
[¥ Detailed Type
V¥ values

4 Click OK to apply the preference and close the dialog box.

A column of check boxes appears in the Procedural entities view.
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Procedural ertities #1327+ Line | ...| % | Detailz | Reviewed

Iﬁ Example_Project 6| 4 0 ] r
F-ADA 1 0 r
(F-PKOATA ! 0 r
[F-RANDOM ! 0 r
[E-RUNTIME_ERROR | 4 m| 23 83 fxampl...| [
dg_ 1 o1 | 2|20 keampl... r
[B-FIBONACCI 3| 14 | 3 (100 exampl..| [T
[B-INFINITE_LOOF 3127 | 3 (100 kxampl..| [T
(B-hAINRTE 3 196 | 3 [100kxampl..| [
bty B s z 2 |2 |100kxampl.| [T
[B-NON_INFINITE_LOOF 3 14 | 3 [100keamp| [

| —PROCEDURE_STUB 3|0 exampl.| [T
[B-PROCEDURE Z0V 1|1 1| 38 |3 |100kxampl.| [T
- 4| 86 |3 |80 exampl..| [T
[B-RECURSION_CALLER i 77| 3 |100kxampl..| [T

| —RECURSIVE 60 | 3|0 exampl. [
[B-SQUARE_ROOT ! 1| 16a | 2 |100kxampl| [T

| v woso 170 | 6 r

| v vz 174 |11 r

| | uovrLs 1| 17a e |pove.| [T
s ! 176 |15 |  Brgume..| [7
[B-SOUARE_ROOT_CONY 3| 18z | 3 (100 kxampl..| [T
(B-UNREACHABLE_CODE ! 1| 182 | 3 |67 pxampl.| [T
L woao 1z | 3 r

The check box for EXCP.5 in SQUARE_ROOT is selected because you selected the
check box for this diagnostic in the current check view (upper- right part
of window).

Tip If you do not see this column, resize Procedural entities so that you see
the column. Resize the column to see the Reviewed label.
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Note Selecting a check box in the Reviewed column automatically:
® Selects the check box for that check in the current check view (upper-right
part of the window).

e Updates the counts in the coding review progress view (upper-left part
of the window).

Reviewing Additional Examples of Checks
In this part of the tutorial, you learn about other types and categories of

errors by reviewing the following checks in example.adb:
e “Example: Unreachable Code” on page 4-16
¢ “Example: A Function with No Errors” on page 4-17

¢ “Example: Division by Zero” on page 4-18

Example: Unreachable Code

Unreachable code is code that never executes. PolySpace software displays
unreachable code in gray. In the following steps, you will look at an example
of unreachable code.

1 In Procedural Entities, expand UNREACHABLE_CODE and click on the
gray ZDV.5.

The source code for this function displays in the source code view.
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179
130
131
1sz
133
154
135
136
157
135
139
120
191
19z
1393
194

1N

= example.adb

=Dl x|

-- Here we demonstrate Polyipace Verifier's ability to
-- jidentify unreachable zections of code due to the
-- walue constraints placed on the wvariahles,

procedure Tnreachable Code iz

X i integer := Randow.random;
¥ ¢ integer := Random.random;
Z @ Integer:
begin

if (=% = w) then

=X ¥

if (x < 0) then

Z=u J1:

end if;

end if;

end Tnreachahle Code;

=]

2 Examine the source code.

At line 190, the code Z := x / Y; is never reached because the condition x
< 0 1is always false.

Example: A Function with No Errors

In the following example, PolySpace software determines, in code with a large
number of iterations, that a loop terminates and a variable does not overflow:

1 In Procedural entities, click on the green NON_INFINITE_LOOP function.

The source code for this function is displayed in the source code view.

4-17
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110
111
112
113
114
115
1lla
117
115
119
120
121
122
123
124
125

]

o4 example.adb

=10l x|

-- Correct operation is demomonstrated because:
-- 1) cur := cur + Z is showm Co newver gererate an aowverflow
-- 2] the loop iz not infinite
big : constant integer := 1073741821; -- Z%%30-3
procedure Non_Infinite_Loop (X : out Integer) is
cur : Integer :=0;
begin
A= 0;
laop
exit when % > big:
cur := cur + Z;

end loop:
A 1= Cur / 100;
end Hon_Infinite_Loop:

Al

-

2 Examine the source code. The variable cur never overflows because the

loop at line 117 terminates before cur can overflow.

Example: Division by Zero
In the following example, PolySpace software detects a potential division

by zero:

1 In Procedural entities, expand RECURSION.

The source code for this function is displayed in the source code view.

4-18
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=
e ——G.  HSBSr> rp»rrrroTi. :J
55 -- If the initial walue passed to Fecursion()] is negatiwe, then

Le -- the recur=ziwve loop will at =Zome polht attempt a diwi=zion

57 -- b¥ =zero.

La procedure Becursion (depth : in out integer):

59 P
&0 procedure Recursive_gZ (depth : in out integer) is

6l begin

B2 Fecur=zion (depth): -- call to Recursziwe procedure

63 end Recursive Z;

64

o5 -- Becursion may lead to zero division

13 procedure Recursion (depth : in out integer) is

67 advance @ float:

1= begin

69 depth := depth + 1;

7a advance := float{l)/float{depth); -- potential =zero division
71 if depth < 5 then

72 Fecursive_Z (depth):

73 advance := float{l)/float(depth);

74 end if;

75 end Recursion; -
i 3

2 Examine the RECURSION function.

When RECURSION is called with depth less than zero, the code at line 70
will result in division by zero. The orange color indicates that this is a
potential error (depending on the value of depth).

Filtering the Types of Checks That You See

You can filter the checks that you see in the Viewer so that you can focus

on certain types of checks. PolySpace software provides three predefined
composite filters, a custom composite filter, and several individual filters. You
learn about filters in the following sections:

¢ “Using Composite Filters” on page 4-20
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¢ “Using the Custom Filter” on page 4-21
¢ “Using Individual Filters” on page 4-23

Using Composite Filters

Composite filters combine individual filters, allowing you to display or hide
groups of checks.

Use this filter... To...

Alpha Display all checks

Beta Hide NIV, NIVL, NIP, Scalar OVFL,
and Float OVFL checks

Gamma Display red and gray checks

User def Hide checks as defined in a custom
filter that you can modify

The default filter is User def. You learn more about the User def filter in
“Using the Custom Filter” on page 4-21. You can select a composite filter
from the filter menu.

User def TI

Filter all
Alpha

Beta
Zamma
Undefined

To learn how the composite filters affect the display of checks:

1 Expand the function PROCEDURE_ZDV in Procedural Entities. Select
Alpha from the filter menu to display all the checks for PROCEDURE_ZDV.
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HE-PROCEDURE_ZDW
e WA
e WA
g WOAT
g WA
- UO0WFL4
- HIVLE
L3 UOVFLE
o A

PROCEDURE_ZDV has eight checks: six green, one gray, and one red.

2 Select Beta from the filter menu to hide the NIV local, SCAL OVFL, NIV
other, and FLOAT OVFL checks.

H-FROCEDURE_ZONV
| vosn
[ s
| wnaz
T
L ¢ zows

Now, only five checks are visible: four VOA, and one ZDV.
3 Select Alpha to display all checks again.

4 Select Gamma to display only the red and gray checks.

da—PHDI:EDUHE_zw

| ¢ vowrLs
| L% zowr

Now, only two checks are visible: the gray UOVFL and the red ZDV.

Using the Custom Filter

The custom filter is a composite filter that you define. It appears on the
composite filter menu as User def and is the default composite filter. By
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4-22

default, the custom filter hides the NIV local, COR, NIV other, and NTL
checks as shown in the following figure.

i

N-ZHR %UJ %E i“LLs JII.Iser-:Ief vI -C.'§,’." Pezistant

NIW ZSCAL I I NIV FLOAT I
lgogl <=0V EXCP hpp | COR POW | thar PERT  qupp  NTC RNTC | NTL UNR. oA

To modify the custom filter:

1 Select User def from the composite filters menu.
2 Select Edit > Custom filters.

The Custom filter setup dialog box appears.

-(ustnm filter setup - PolySpace Viewer

Select the checks or colors ta hide when the custom fiter is set.

Check Filters Color Fitters “ariable Type Fiters
IV Hor-In [ Gray Checks [ Mor-Shared Varishles
™ Zero Division Checks r Crange Checks
I~ Artthmetic Exceptions Checks ™ Green Checks
™ Scalar Overflow Checks ™ Errors in non executable procedures
[V Correcthess Condtion Checks ™ Orange not cortaining additional infarmation

I Powver must be positive Checks
[+ Mon-Initislized Yatishle Checks

Float / Scalar Fitters
™ User Assertion Checks

I™ Float Checks
I Float Overflow Checks

I™" Unknawsn MNon-Termination of Call Checks L
™ Known Mon-Termination of Call Checks
IV Mar-Termination of Loop Checks

[ Unreachakle Code Checks

™ walug On Assigned (only displayed, not courted)

Ok | Apply | Cancel |

I s 3]

3 Clear the filters for the checks that you want to display. For example,
if you clear the Non-Initialized Local Variables Checks box, these
checks display.
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Note You do not have to change any of the selections for this tutorial.

4 Select the filters for the checks that you do not want to display.
5 Click OK to apply the changes and close the dialog box.

PolySpace software saves the custom filter definition in the Viewer
preferences.

Using Individual Filters

You can use an individual filter to display or hide a given check category.
When a filter is enabled, that check category is not displayed. For example,
when the VOA filter is enabled, VOA checks are not displayed. When the
VOA filter is disabled, VOA checks are displayed. You can also filter by check
color. To enable or disable an individual filter, click the toggle button for that
filter on the toolbar.

Tip When you mouse over a filter button, a tooltip tells you which filter the
button is for and whether the filter is currently enabled or disabled.

To learn how an individual filter affects the display of checks:

1 Expand PROCEDURE_ZDV.
2 Select Alpha from the composite filters menu to display all checks.

3 Click the NIV local filter button

NIY
local
to hide the NIVL checks for PROCEDURE_ZDV.
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[E-FROCEDURE_ZDW
= WOAD
Y TR
e WA
- WA
L UOWFLA
3 UOWFLE
. =L

4 Click the NIV local filter button again to display the NIVL checks.
5 Now click the green checks filter button

~

to hide the green checks.

d;l—F‘FtDEEDUFtE_ZD'v'

| ¢ vovrLs
| L% zovr

Note When you filter a check category, some red checks within that category
are still displayed. For example, if you filter ZDV checks, ZDV.7 is still
displayed under PROCEDURE_ZDV.
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Reviewing Results in Assistant Mode

In this section...
“What Is Assistant Mode?” on page 4-25

“Switching to Assistant Mode” on page 4-25

“Selecting the Methodology and Criterion Level” on page 4-26
“Exploring Methodology for Ada” on page 4-26

“Reviewing Checks” on page 4-28

“Defining a Custom Methodology” on page 4-30

What Is Assistant Mode?

In assistant mode, PolySpace software chooses the checks for you to review
and the order in which you review them. PolySpace software presents checks
to you in this order:

1 All red checks

2 All blocks of gray checks (the first check in each unreachable function)

3 Orange checks according to the selected methodology and criterion level

You will learn about methodologies and criterion levels in “Selecting the
Methodology and Criterion Level” on page 4-26.

Switching to Assistant Mode

If the Viewer is in assistant mode, the switch mode button displays Expert.
If the Viewer is in expert mode, the switch mode button displays Assistant.
To switch from expert mode to assistant mode:

. . ' G Assistant
® (Click the Viewer’s switch mode button

The Viewer window toolbar displays controls specific to assistant mode.
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JIMethndnlngy for Model Based Designedj r— |_ Skip gray chechks 4 <§ '@}' §> [
1 2 a

4-26

The controls for assistant mode include:

® A menu for selecting the review methodology for orange checks
e A slider for selecting the criterion level within that methodology
¢ A check box for skipping gray checks

® Arrows for navigating through the reviews

Selecting the Methodology and Criterion Level

A methodology is a named configuration that defines the number of orange
checks, by category, that you review in assistant mode. Each methodology
has three criterion levels. Each level specifies the number of orange checks
for a given category. The levels correspond to different development phases
that have different review requirements. To select the methodology and level
for this tutorial:

1 Select Methodology for Ada from the methodology menu.

Ihﬂethndnlngy far Model Based Designed;l

Mlethod or Ada
Methodaology for ©

Methodology for C++
Methodology for Model Based Designed

2 If the level slider is not already at 1, move the slider to level 1.

Exploring Methodology for Ada
In this part of the tutorial, you examine the configuration for Methodology
for Ada. To begin:

1 Select Edit > Preferences.



Reviewing Results in Assistant Mode

The Preferences PolySpace Viewer dialog box appears.

2 Select the Assistant configuration tab.

The configuration for Methodology for Ada appears.

On the right side of the dialog box, a table shows the number of orange
checks that you review for a given criterion and check category.

smeous | Assistant configuration |

CCommon
Z0
Ml L
S-O%FL
COR
Py
P
F-CFL
ASRET

~Murber of checks to review

Criteriamn 1 Criterion 2 Criterian 3
10 20 AL
LT a0 AL
ALITC a0 AL
LT 10 10
AT 10 AL
ALITC 5 10
3 10 20
ALITC 5 20

For example, the table specifies that you review ten orange ZDV checks
when you select criterion 1. The number of checks increases as you move
from criterion 1 to criterion 3, reflecting the changing review requirements

as you move through the development process.

In the lower-left part of the dialog box, the section Review threshold
criterion contains text that appears in the tooltip for the criterion slider

on the Viewer toolbar (only in assistant mode).
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Configuration set

hethodology for Ada LI

Feview threzhaold criterion

Criterion 1 Fresh code
Criterion 2 it tested
Criterion 3 Code reviesn

For the configuration Methodology for Ada, the criterion names are:

Criterion Name in the Tooltip
1 Fresh code

2 Unit tested

3 Code review

These names correspond to phases of the development process.

3 Click OK to close the dialog box.

Reviewing Checks

In assistant mode, you review checks in the order in which PolySpace software
presents them:

1 All reds

2 All blocks of gray checks (the first check in each unreachable function)

Note You can skip gray checks by selecting the Skip gray checks check
box in the toolbar.

3 Orange checks according to the selected methodology and criterion level
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Earlier in this tutorial, you selected Methodology for Ada, criterion 1. In this
part of the tutorial, you continue to review the checks for example.adb using
this methodology and criterion level. To navigate through these checks:

1 In the procedural entities view (lower left), PROCEDURE_ZDV is expanded
and ZDV.7 is displayed as the current check.

If the Viewer is displaying the message “No check currently selected” in the
upper-right portion of the window, then you will need to click the forward

arrow to go to the first check.

Procedural entties

ﬁ Ezample_Project

[B-RUNTIME_ERROR

H-CLOSE TO_ZERO

H-FIBONACC]

- INFINITE_LOOR

[G-PROCEDURE_ZD0Y
y

_$OUARE ROOT

- 3QUARE_ROOT_CONY

e [

The source code view (lower right) displays the source for this check and
the current check view (upper right) displays information about this check.

Note You can display the calling sequence and track review progress as
you did in “Reviewing Results in Expert Mode” on page 4-9.

2 Continue to click the forward arrow until you have gone through all of
the checks.

After the last check, a dialog box appears asking if you want to start again
from the first check.
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4-30

Wrapping search ]|

@ End of the set of checks under review,
Do wiou wank bo skark again From the First check?

3 Click No.

Defining a Custom Methodology

You cannot change the predefined methodologies, such as Methodology for
Ada, but you can define your own methodology. In this part of the tutorial,
you learn how to create and use your own methodology.

To define your custom methodology:

1 Select Edit > Preferences.

The Preferences PolySpace Viewer dialog box appears.
2 Select the Assistant configuration tab.
3 Select Add a set from the menu in Configuration set.

4 In the Create a new set dialog box, enter My methodology for the name
and click Enter to close the dialog box.

5 Under the Criterion 1 column, enter the number 1 next to ZDV . This tells
PolySpace software to select up to one orange ZDV for review. PolySpace
will not select any other orange checks for review because you are leaving
all of the other fields blank.

This does not affect the red and gray checks: the software will still present
all red checks and the first check in each unreachable function for review.

6 Click OK to save the methodology and close the dialog box.

To use My methodology:
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1 Select My methodology from the methodology menu.

2 If the level slider is not already at 1, move the slider to level 1.

3 Click the forward arrow 4 to review the checks.

With this methodology at criterion 1, the only orange check you review
is the orange ZDV.5 in RECURSION.

4 End PolySpace Viewer by selecting File > Quit.
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Generating Reports of Verification Results

Generating a Report of the example.adb Verification

You can generate a Microsoft Excel® report of the verification results.
To generate an Excel report of the verification results for the package
example.adb:

1 Navigate to polypace_project\results\PolySpace-Doc.
The directory should have the following files:

Example Project_Call Tree.txt
Example_Project_RTE_View.txt

Example Project_Variable_View.txt
Example_Project-NON-SCALAR-TABLE-APPENDIX.ps
PolySpace_Macros.xls

The first three files correspond to the call tree, RTE, and variable views
in the PolySpace Viewer window. For more information about the Viewer
window, see “Exploring the Viewer Window” on page 4-5.

2 Open the macros file PolySpace Macros.x1s.
A security warning dialog appears.
3 Click Enable Macros.

A spreadsheet appears. The top part of the spreadsheet looks like this.
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Apply filters? ———— Generate checks by file?
Mo filters & ves
" Beta filters “ no

Help | Use this button to create the complete synthesis in one file Help

Select the RTE export view and a file in which to save results
[f the other views are in the same directory as the RTE view
then they will automatically be incorporated into the same file

Generate PolySpace Results Synthesis |

4 In the top half of the spreadsheet, in Apply filters?, select No filters.
5 In Generate checks by file?, select the yes.
6 Click Generate PolySpace Results Synthesis.

The synthesis report combines the RTE, call tree, and variables views into
one report.

The Select a RTE View text file dialog box appears.
7 In Look in, navigate to polypace _project\results\PolySpace-Doc.
8 Select Example Project RTE_View.txt.
9 Click Open to close the dialog box.

The Where should I save the analysis file? dialog box appears.

10 Keep the default file name Example Project-Synthesis and file type
Microsoft Excel Workbook(*.x1ls)

11 Click Save to close the dialog box and start the report generation.

Microsoft Excel opens with the spreadsheet that you generated. This
spreadsheet has several worksheets:
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E Microsoft Excel - Example_Project-Synthesisads

] File Edit Wiew Insert Format Tools Data Window Help

A B| C |D|E
1 |Procedural entities IR | O |Gy|Gn
2 |Example Project 17 6B | 6|37
3 || -aDa
4 || | -HUMERICS
511 | | -AUX
61 | | | Cos
T 11| SQRT
8 || -FPEDATA
9 || | ARRAY OVERFLOW_INIT
10| | HON_INTRUSIVE INFORMATIONS
11|] -RANDOM
12|] | RANDOH
13| | RANDOMSZ
14| | RANDOMS3
15 || —-RUNTIME_ERRCOR 7 6B | 5|37
16| | -CLOSE _TC _ZEROD 4
7] | | ¥ ¥oA.0
18] | | ¥ woAa.l
19(] | | 7+ UQOVFL.2
2000 | | W wWoA. 3
211 | | W Woa. 4
201 | | * UO¥FL.S
23] | | W ZDV.&
240 | | * UO¥YFL.?
251 | | ® O¥VFL.&
26| | -FIBOHACCI
27 | | W wWoA.Q
280 | | W wWoA.l
20/ | | W WoA.Z
A0 | | ¥ WoA.3
M A4 F M r*-, RTE Checks Sheet 1/ Launching Options 4 Check Synthesis
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12 Select the Check Synthesis tab to view the worksheet showing statistics

by check category:

E Microsoft Bxcel - Example_Project-Synthesis.xds

M 4 » Hr\ RTE Checks Sheet 1 £ Launching Options i Check Synthe

Eﬂ File Edit Aew Insert Format Tools Data  Window  Help
A B IcID|E|F

1 RTE Statistics

2 | Check category Check detail RO |Gy |G

3 |OBAl COut of Bounds Array Index 00 |0

4 |NIWVL Uninitialized Local Yariable 001

5 |IDF llegal Dereference of Pointer |0 (0 |0

6 [MIP Uninitialized Pointer 0|00

¥ MW Lninitialized Variable oo |2

8 |IRW Initialized Valug Returned 0|0

9 |[COR Other Correctness Conditions |00 |0

10 [ASRET User Assertion Failure 000

11 [POVY Fower Must Be Positive 000

12 7DV Division by Zero 1111

13 [SHF Shift Amount Within Bounds 0|0

14 |OVEL Cwverflow 0|2 1|0

15 |LINFL Underflow 0|0 1|0

16 |UOWFL Underflow or Overflow 0|32

17 [EXCP Arithmetic Exceptions 11010

18 |NTC Maon Termination of Call 410 (0

19 [k-MTC Fonown Man Termination of Call |00 |0

20 |[NTL Mon Termination of Loop 10 (0

sis
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